Один раз мне нужно было установить расширение phpmailer для yii и для меня стало сюрпризом, что после команды

composer require --prefer-dist zyx/zyx-phpmailer "@stable"

Консоль выдала целый залп ошибок. Вот подобные:

Deprecation Notice: The Composer\Package\LinkConstraint\MultiConstraint class is deprecated, use Composer\Semver\Constraint\MultiConstraint instead. in phar://D:/OpenServer/modules/php/PHP-5.4/composer.phar/src/Composer/Package/LinkConstraint/MultiConstraint.php:17

Выполнение команды

composer update

Выдавало такие же ошибки:

composer-error

И вот нашел на каком-то форуме решение. Как оказалось, надо всего лишь переустановить плагин для composer.

$ composer global require "fxp/composer-asset-plugin:~1.1.1"

Проблема решена!