Категория: Разработка сайтов

Поддержка загрузки файлов webp для wordpress без плагинов

Стандартно wordpress не поддерживает загрузку изображение в медиатеку в формате webp. Чтоб это исправить нужно внести правки в файл темы functions.php.

Подробнее

WordPress

Как отключить обновления WordPress?

При создании сайта на популярной системе WordPress, не всегда получается следить за всеми обновлениями. Например, обновления ядра WordPress, обновления плагинов, обновления темы. Так же довольно часто, после обновлений перестает работать какой-то функционал или вылетают ошибки.

Подробнее

basic yii2

Отключение отладочной информации (Debug Mode) Yii2

Для отключения отладочной информации необходимо закомментировать приведенные ниже строки в конфигурационном файле.

// Настройки для разработки и отладки
/*
if (!YII_ENV_TEST) {
// configuration adjustments for 'dev' environment
$config['bootstrap'][] = 'debug';
$config['modules']['debug'] = 'yii\debug\Module';

// Конфигурация для работы с GII
$config['bootstrap'][] = 'gii';
$config['modules']['gii'] = 'yii\gii\Module';
$config['modules']['gii'] = ['class' => yii\gii\Module::className(),'allowedIPs' => ['127.0.0.1', '::1']];
}
*/

 

yii&openserver

Установка шаблона AdminLTE на yii2 basic

AdminLTE очень удобный и навороченый административный шаблон для управления контентом.

Установка данного шаблона на yii2 basic сводится к нескольким шагам. Итак, давайте их рассмотрим.

Подробнее

basic yii2

Установка и настройка yii2 basic

Установка yii2 basic

Установить yii2 basic можно двумя вариантами: через composer и через скачанный архив с сайта разработчика.

Тут будет описана установка через composer.

Итак, запускаем Консоль на OpenServer.

Подробнее

composer ошибка

Ошибка при composer update и при установке расширений

Один раз мне нужно было установить расширение phpmailer для yii и для меня стало сюрпризом, что после команды

composer require --prefer-dist zyx/zyx-phpmailer "@stable"

Консоль выдала целый залп ошибок. Вот подобные:

Deprecation Notice: The Composer\Package\LinkConstraint\MultiConstraint class is deprecated, use Composer\Semver\Constraint\MultiConstraint instead. in phar://D:/OpenServer/modules/php/PHP-5.4/composer.phar/src/Composer/Package/LinkConstraint/MultiConstraint.php:17

Выполнение команды

Подробнее

yii&openserver

Установка yii2 на OpenServer

PHP фреймворк Yii2 использует версию PHP не ниже 5.4. Рассмотрим как установить его на OpenServer (как установить OpenSever).

Заходим в настройки сервера и выставляем версию как показано на рисунке

OpenServer настройка версии PHP

Подробнее

All rights reserved. 2015-2021.