Работа с типом Массив в 1С довольно востребовательна.

Массив предназначен для для упорядоченного хранения информации, различных типов данных. Доступ к элементам массива доступен по индексам в виде [Индекс]. Нумерация элементов массива начинаются с нуля. Обход всех элементов массива возможен при использовании конструкции Для каждого … Из … Цикл.

Массив поддерживает такие методы:

  • ВГраница() - Возвращает наибольший индекс элемента массива;
  • Вставить(Индекс, Значение) - Вставляет Значение в массив по Индексу;
  • Добавить(Значение) - Добавляет новый элемент в конец массива;
  • Количество() - Возвращает количество элементов в массиве (число);
  • Найти(Значение) - Производит поиск элемента в массиве. Если элемент найден в массиве, тогда возвращается его индекс. Если элемент не найден в массиве, тогда возвращается Неопределено;
  • Очистить() - Очистка массива, удаление всех значений из массива;
  • Получить(Индекс) - Получает значение по указанному Индексу. Работает как оператор [];
  • Удалить(Индекс) - Удаляет значение из массива индексу;
  • Установить(Индекс, Значение) - Устанавливает значение по указанному Индексу, предыдущее значение удаляется.

Примеры:

/// Создадим массив (нужного размера) в 1с 8.3, 8.2

Процедура СоздатьМассив(Команда)
 
    // массив на 2 элемента
    Массив = Новый Массив(2);
 
    // добавим новые значения (строки)
    Массив[0] = "Первый";
    Массив[1] = "Второй";
 
    // выведем значения элементов
    Для Каждого МассивЭлемент из Массив Цикл
        Сообщить(МассивЭлемент); // Первый Второй
    КонецЦикла;
 
КонецПроцедуры
/// Создадим новый пустой массив 1с 8.3, 8.2

Процедура СоздатьНовыйМассив()
 
    // создать пустой массив
    Массив = Новый Массив;
 
    // добавим новые значения (числа)
    Массив.Добавить(2);
    Массив.Добавить(4);
    Массив.Добавить(6);
    Массив.Добавить(8);
    Массив.Добавить(10);
 
    // сообщим значения элементов
    Для Каждого МассивЭлемент из Массив Цикл
        Сообщить(МассивЭлемент ); // 2 4 6 8 10
    КонецЦикла;
 
КонецПроцедуры
/// найдем значение в массиве 1с 8.3, 8.2

Процедура НайтиЗначениеВМассиве()
 
    Массив = Новый Массив;
 
    // добавим новые значения
    Массив.Добавить(2);
    Массив.Добавить(4);
    Массив.Добавить(6);

    //Найдем элемент со значением 4, если он существует удалим его 
    НайденныйИндекс = Массив.Найти(4);
    Если НайденныйИндекс <> Неопределено Тогда
        Массив.Удалить(НайденныйИндекс);
    КонецЕсли;
    
    Массив.ВГраница();   // 1 (то есть 2 значения 0 и 1)
    Массив.Количество(); // 2
 
КонецПроцедуры

В примерах показаны базовые принципы работы с массивами. На практике часто встречаются довольно сложные конструкции с использованием массивов.

В комментариях можете задавать интересующие Вас вопросы, по возможности буду отвечать.